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Lesson 3 

Analyzing, Organizing and 
Sharing Workbooks 

⁞ Lesson Objectives 
 
In this lesson, you will look at various methods of analyzing, organizing, linking and sharing workbooks. On 

successful completion of this lesson, you will be able to: 

 sort data 

 use the AutoFilter feature to find specific data 

 create, modify and delete range names 

 create, modify and delete hyperlinks  

 create and delete comments 

 import and export data with other programs 

 change workbook document properties 

 use Office BackStage to share workbooks with others  
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⁞ Sorting Data  
Worksheets with a large amount of data are often difficult to understand. Excel provides a sorting tool that enables 

you to change the sequence of the data based on the values in selected columns. After sorting, the data becomes 

more readable. You can sort and re-sort the data as many times as required, using different columns each time. You 

can sort the data by columns or rows, but the most common method is sorting by rows (with column headers and the 

data extending downwards). 

Sorting by Single-Level Data  
The Ribbon offers the quickest method of sorting your data, but you are limited to sorting by one column. The Ribbon 

has two ready-to-use buttons for this: 

 on the Home tab, in the Editing group, click Sort & Filter and then click Sort A to Z or Sort Z to A, or 

 on the Data tab, in the Sort & Filter group, click Sort A to Z or Sort Z to A. 

          

Sorting by Multi-Level Data  
In many cases, you will need to sort by more than one column to handle situations with multiple rows with the same 

value (e.g., a list of names where several people have the same last name). Excel allows you to choose the custom 

sort option, which displays the sort dialog box.  

This dialog box provides a comprehensive set of options for sorting your data: 

 

Add Level, 
Delete Level, 
Copy Level 

Add, delete or copy sort columns or rows. Note that the topmost sort key is the highest 

(primary) sorting level, followed by the remaining levels in descending order.  

Move up / 
Move down 

Move the selected sort level higher or lower in the sorting sequence.  

Options Sort by columns or rows, and choose whether to be case-sensitive.  

My data has 
headers 

Tell Excel to treat the first row of cells as data or field labels. 

Column/Row Identify the column or row to be used for a sort level.  

Sort On Includes (cell data) Values, Cell Color, Font Color, or Cell Icon.  
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Order Sort data in ascending (A to Z, Smallest to Largest) or descending (Z to A, Largest to 

Smallest) order. 

Sort by Determine the first column or row Excel will use to sort the database—the primary sort level. 

Then by Determine the next columns or rows for sorting, if necessary. When there are multiple rows 

that match the primary sort key, this determines the sort order within the first column 

grouping.  

With the Sort dialog box, if the primary sort level contains repeating values, you can choose up to 64 columns or rows 

as sort levels. You can sort the data in each sort level in ascending or descending sequence. Each sort level can also 

be sorted using the cell data, fill color, font color or by cell icon. 

If the range of cells being sorted does not contain column or rows headers, turn off the My data has headers option. 

Use this option to prevent sorting the header data together with the other data—they will remain in their place as 

headers. 

 

Learn the Skill 
This exercise demonstrates how to sort a table of data using one column, and then multiple columns, as 
sort keys. 

1 Open the Flights workbook and save it as Flights ‐ Student.  

First, sort the data using a column containing text data.  

2 Select any cell in the Airline column.   

3 On the Home tab, in the Editing group, click Sort & Filter and then click Sort 

A to Z. 

 You have now sorted the data by airline name. Look closely to see how Excel 

has sorted the data for each group of rows with the same airline name.  

  

Now sort a column containing numbers in descending order (largest values at the top to the smallest values at 

the bottom). 

4 Select any cell in the Flight # column. 

5 On the Home tab, in the Editing group, click Sort & Filter and then click Sort Largest to Smallest. 

 Now try sorting by a column containing time data in ascending order.  

6 Select any cell in the Departure Time column. 

7 On the Data tab, in the Sort & Filter group, click Sort Smallest to Largest. 

Note… 
Be sure to select a cell below 
the header row —Excel 
determines how to sort for 
the column based on the 
type of data in the selected 
cell. 
This sort button is also 
available in the Data tab. 
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Now sort the data using two columns. 

8 Ensure that the active cell is anywhere within the data range, then on the Home tab, in the Editing group, 

click Sort & Filter and then Custom Sort. 

 Excel displays the Sort dialog box.  

9 Ensure that you have selected My data has headers. 

10 Click the arrow next to the Sort by field and click Destination. 

The Destination column is the primary sort key. Use the Departure Time column as the secondary sort 

key.  

11 Click Add Level to add another sort key. 

12 Click the arrow for Then by and then click Departure Time. 

13 Click OK. 

Now add a third sort key. 

14 On the Data tab, in the Sort & Filter group, click Sort. 

15 Click on the Then by row to select that row. The best area to click is on the Then by text so that you do 

not click in any of the selection fields. 

16 Click Add Level to add another sort key below the existing rows. 

17 Click the arrow for the second Then by and then click Airline. 

18 Click the arrow next to the Order field for the second Then by and click Z to A to sort this field in 

descending order.  

Note…
You can also open the 
Sort dialog box from the 
Data tab.
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19 Click OK. 

Delete the middle sort sequence.  

20 On the Data tab, in the Sort & Filter group, click Sort. 

21 Click on the first Then by row to select that row.  

22 Click Delete Level and click OK.  

The list is now sorted first by destination in ascending order and then by airline in descending order. The 

worksheet now looks similar to the following example: 

  

23 Save and close the workbook. 

⁞ Filtering Information 
Worksheets are often used to store large amounts of data. Finding information in large worksheets is often difficult 

because of the sheer volume. Sorting the rows is one way of making it easier to find information; however, you still 

have to look through many if not all the rows in the worksheet. Another way to locate information quickly is to use a 

filter to hide the rows you are not interested in viewing. Filtering does not change the content of your worksheet or the 

sequence of the rows (like the way sorting does), only what you see of your worksheet. 
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The quickest and easiest way to filter data in Excel is to use the AutoFilter tool. When you activate this tool, Excel 

places AutoFilter icons on the right side of each of the column titles. Use these icons to specify the selection criteria 

that Excel uses to display the records.  

In its simplest form, the AutoFilter finds and displays the rows where the value in the selected column is equal to a 

specific value.  

 

The AutoFilter has the flexibility to help you build more complex queries, which you can use to narrow down the 

results and avoid selecting rows that you do not want. For example, you can select criteria that examine two or more 

columns, or that are equal to one of two or more values. In addition, Excel provides powerful selection criteria that are 

specific to columns containing text, numbers or dates, such as the following:  

Numbers Evaluate data in the selected column with the commonly used 

comparison operators (equals, greater than, less than, greater than 

or equal to, between and so on) as well as the Top 10 values (or 

rows with values above or below the average of all values in the 

column).  
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Dates Evaluate date-type data using special criteria that are specific for 

dates, such as comparing the date of today with tomorrow, 

yesterday, this/next/last week, this/next/last month, this/next/last 

quarter, this/next/last year or year to date. 

 

 

 

 

 

 

 

Text Evaluate text data using special criteria that are specific to text, 

such as begins or ends with (text), or contains or does not contain 

(text).  

 

 

Learn the Skill 
This exercise demonstrates how to use AutoFilters in various ways on a worksheet. 

1 Open the Flights workbook. 

Do a quick visual scan of the worksheet to see how many rows are in it.  

2 Scroll down to the bottom of the data (row 1121), then scroll back to the top.  

Activate the AutoFilter and select all rows for a specific airline.  

3 Select any cell in the data (between cells A2:D1121). 

4 On the Data tab in the Sort & Filter group, click Filter.  

  

 

Note… 
Another way of activating 
the AutoFilter icons is on the 
Home tab, in the Editing 
group, click Sort & Filter 
and click Filter. 
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 AutoFilter arrows now appear next to each field name: 

  

5 Click the AutoFilter arrow for the Airline column. 

 The AutoFilter menu displays a list of every unique value in this column. You set the filter by turning the 

check box on or off for the value(s) you want.  

  

6 Click Select All to turn it off. 

7 Scroll down the list, click Lufthansa to turn it on and click OK. 

Notice the row numbers of the records that remain displayed from the database. Excel hides the rows that 

do not meet the criteria and displays only records that have a matching value in the filtered field. Excel 

also changes the AutoFilter icon to indicate that it is using a field to limit the records displayed. 

Now redisplay all records. 

8 Click the AutoFilter arrow for the Airline column and click Clear Filter From “Airline”. 
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Note… 
Another way of clearing 
filter criteria is to click 
AutoFilter and then click 
Select All to turn it on, or, 
on the Data tab, in the 
Sort & Filter group, click 
Clear. 

The conditions you select are called filter criteria. You can also set up criteria for 

date, time and numeric values.  

9 Click the AutoFilter arrow for the Departure Time column, click Select All to turn it 

off. Click 6:00 AM to turn that check box on and click OK. 

You can set date, time and numeric AutoFilters to look for a range of values using 

comparison operators such as greater than, less then, between and more. 

Suppose you want to find all flights departing between 2 PM and 3 PM. Text fields contain a similar set of 

comparison operators. 

10 On the Data tab, in the Sort & Filter group, click Clear. 

11 Click the AutoFilter arrow for the Departure Time column, click Number Filters and then click Between.  

12 Select the departure time values as shown in the following example screen: 

  

13 Click OK. 

 The results should look similar to the following example: 

  

 The AutoFilter selection menu includes a search field that you can use to find the filter values you are 

looking for quickly instead of scrolling up and down the list. In effect, you are applying a filter to the filter 

values. Suppose now that you want to find flight 8778. You can search for 8778. You can also use shorter 

search criteria, which will find all filter values that contain this search value in it.  

14 On the Data tab, in the Sort & Filter group, click Clear. 

15 Click the AutoFilter arrow for the Flight # column. Then type 87 in the Search text box (located above the 

Select All check box) to display a list of all values with 87 in it.  
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16 Click the Select All Search Results check box to turn it off. Then click the 8778 check box to turn it on 

and click OK. 

  

 Excel does not limit you to selecting rows using only one value; you can also select multiple values for a 

single column.  

17 On the Data tab, in the Sort & Filter group, click Clear. 

18 Click the AutoFilter arrow for the Airline column and click Select All to turn it off. Click KLM Royal Dutch 

and Lufthansa to turn them on and click OK. 

 The results should look similar to the following example: 

  

You may also select criteria across multiple fields. For example, try selecting all rows where the destination is 

Fort Lauderdale and the airline is KLM or Lufthansa.  

19 Click the AutoFilter arrow for Destination, click Select All to turn it off and then click Fort Lauderdale, FL 

(FLL) to turn only that check box on. Click OK. 

  

 This list shows that there are four flights departing today for Fort Lauderdale.  

Now turn off the AutoFilter feature. 

20 On the Data tab, in the Sort & Filter group, click Filter. 

21 Close the workbook and discard the changes.  
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⁞ Working with Named Ranges  
Creating Named Ranges  
When developing spreadsheets, you will find that they quickly become very large and it becomes difficult to keep 

track of all the cells. One feature in most spreadsheet programs is the ability to create a name for a cell or range of 

cells. It is much easier to understand the formula =Revenues-Expenses than a cryptic formula such as =C7-C16. 

To define a range with a name, select the range and then use one of the following methods: 

 On the Formulas tab, in the Defined Names group, click Define Name; or 

 click in the Name Box and type the name; or 

 right-click the selected range and then click Define Name. 

Once you define a name for a cell or a range of cells, you can use that name when creating formulas. Excel also 

provides tools for applying range names to your existing formulas. 

You can also quickly jump to a named range by using Go To or by selecting the named range from the Name Box 

list to the left of the Formula bar. 

In addition to making spreadsheets easier to read, range names can make the process of entering cell data easier. 

Simply changing the range defined by a range name updates all formulas that use that range name; therefore, there 

is no need to edit every formula in the spreadsheet. 

Range names can be from 1 to 255 characters in length. They may contain alphabetic or numeric characters 

(alphanumeric), underscores (_), backslashes (\), periods (.) and question marks (?). You cannot use spaces in range 

names. The first character must be alphanumeric, an underscore or a backslash. 

Modifying and Deleting Named Ranges 
You can use the Name Manager to modify and delete range names or change the cell range references.  

Be cautious when deleting named ranges. When you delete a named range, any formula that refers to this name no 

longer displays the correct value. Deleting a range name may also cause a domino effect with other formulas that 

indirectly refer to this formula. 

 

Learn the Skill 
This exercise demonstrates how to create range names and set up formulas using those range names. 

1 Open the Income Statement workbook and save as Income Statement ‐ Student. 
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Now create a range name to use in sales calculations. 

Excel can use either row or column headers as range names. However, this is not a good practice because 

formulas using this range name will often not recalculate correctly if you (or someone else) add more data. You 

should explicitly create range names instead. 

2 Select cells C5:C6. 

3 On the Formulas tab, in the Defined Names group, click Define Name. 

 The New Name dialog box displays with the cell range entered. 

   

4 In the Name field, type: Revenues and click OK. 

 From now on, whenever you select these two cells, the range name Revenues displays in the Name Box, 

which appears to the left of the Formula Bar. If you click the arrow at the right side of the Name Box and 

select a range name, Excel will select that range of cells.  

  

5 Select each of the cells in the cell range C5:C6 and observe what displays in the Name Box.  

6 Select the cell range C5:C6 and observe what displays in the Name Box.  

7 Select cells C10:C16. On the Formulas tab, in the Defined Names group, click Define Name. 

8 In the Name field, type: Expenses and click OK. 

Now enter summary formulas using this range name.  

9 Select cell C7. 

10 Type: =SUM(Revenues) and press . 

 Notice that as you type the first one or two characters of the range name, a quick tip box appears, showing 

you this name and other functions with similar names. You can double-click the range name in the quick 

tip box to select it 

  

11 Select cell C17, type: =SUM(Expenses) and press . 

Note… 
Range names are not 
case sensitive. Fo
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You can also create a range name by selecting the desired cell(s) and clicking in the Name Box on the 

Formula bar. Then type the desired name and press . 

12 Select cells B7:C7. 

13 On the Formulas tab, in the Defined Names group, click Create from Selection. 

   
14 Click Left column to turn it on and click OK.   

15 Select cell C7.  

 Note that the range name in the Name Box is Total_Revenues. 

Create a range name for the Total Expenses cell, but this time using the Name Manager.  

16 Select cell C17.  

17 On the Formulas tab, in the Defined Names group, click Name Manager. 

 The Name Manager dialog box is now displayed.  

18 In the Name Manager dialog box, click New to create a new range name. 

   

19 Verify that the Name is Total_Expenses and that the Refers to field contains the formula =Sheet1!$C$17. 

Click OK. 

If the New Name dialog box is blocking access to the worksheet behind it, you can minimize it temporarily 

by clicking the Expand button to the right of the Refers to field. You can then select a range of cells from 

the worksheet. 

  
 The Name Manager dialog box now has this new range name added, similar to the following example: 

 

Note… 
Excel does not permit 
blank spaces in range 
names. You can use the 
underscore character 
between the words in a 
multi-word range name. 
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20 Click Close to close the Name Manager dialog box. 

Enter the formula to calculate the Net Income, using the range names.  

21 Select cell C19, and type: =  

22 On the Formulas tab, in the Defined Names group, click Use in Formula. 

  

23 Click Total_Revenues, then press  to indicate that you are going to perform a subtraction. 

24 On the Formulas tab, in the Defined Names group, click Use in Formula. Click Total_Expenses and 

press . 

 The completed worksheet will look similar to the following example: 
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 A common situation is adding more rows to a named range. As long as you add the rows inside the range, 

Excel automatically includes the new data as part of the range. If you add the new data below the range, 

you will need to expand the range to include the new row(s). 

25 Click the gray header for row 17 to highlight the entire row. Right-click in the highlighted row and click 

Insert in the menu. 

26 Select cell B17, type: Travel and press . 

27 In cell C17 type: 1400 and press . 

 Note that none of the figures in the report changed because the new entry sits outside of the named range 

Expenses. Now expand the named range to include the new entry.  

When you first created the range name, you could have included additional blank cells for future growth. 

Then, as you add new entries to the list, Excel automatically recalculates the total expenses formula. 

28 On the Formulas tab, in the Defined Names group, click Name Manager. 

29 In the Name Manager dialog box, click the Expenses row to select it. 

30 In the Refers to text field, change the range to =Sheet1!$C$10:$C$17 as the range. 

31 Click Update (the checkmark) to the left of the field to update the changes, and click Close. 

 The worksheet should now show the correct calculations for each of the functions, similar to this example: 

  

Try deleting a named range and see how it affects the worksheet.  

32 On the Formulas tab, in the Defined Names group, click Name Manager. 

33 Click the Revenues row and then click Delete. 

 Excel displays a message box asking you to confirm the deletion of this range name.  

34 Click OK for the confirmation message box and then click Close to close the Name Manager dialog box.  

 As shown in the following example, when you remove a named range, Excel displays an error indicator 

regarding any formulas that depend on that name. Note also that the change has affected the formula in 

cell C20 as well, even though it does not use the range name Revenues directly.   
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35 In the Quick Access Toolbar, click Undo.  

36 Save and close the workbook.  

⁞ Using Hyperlinks 
A hyperlink is a clickable element in an electronic document that you can use to jump to or open another document. 

The World Wide Web consists of web pages (which are essentially documents) containing text, images, videos and 

hyperlinks to other web pages. You can insert hyperlinks into workbooks to enable the same capability of launching 

web pages from the Internet or an internal corporate intranet, or open documents located on any computer within 

your local area network.  

A hyperlink can be text or a picture on a page that links you from where you are to another location. This allows you 

to “jump” to that location, which may be in the same document, another document, a document or page on another 

Web site or an e-mail address. 

Inserting Hyperlinks 
By clicking a hyperlink, you can display the referenced document. Each hyperlink contains a code in the form of a 

Uniform Resource Locator (URL), which is the unique address for this document or page at this particular location on 

the Internet or intranet. 

URLs can be stored in Excel worksheets or workbooks and used as hyperlinks to jump to other documents on the 

Internet or intranet, other Excel workbooks or other Microsoft Office documents. 

To insert a hyperlink, use one of the following methods: 

 On the Insert tab, in the Links group, click Hyperlink; or 

 right-click on a cell and click Hyperlink; or 

 press + . 
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The displayed Insert Hyperlink dialog box allows you to insert one of four types of hyperlinks: 

Existing File or 

Web Page 
 

Used to link to workbooks, files, or documents stored on a local or networked hard drive, or 

on the intranet or the Internet. 

 

Place in This 

Document 

Used to link to a cell or named range of cells in the current workbook, either in the current 

worksheet or another worksheet. 

 

Create New 

Document 

Used to create a new workbook using the name that you specify in the Name of new 

document text box and located in the folder specified under Full path. 
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E-mail Address Used to launch the e-mail program (e.g. Outlook) installed on the local computer, and 

create a new e-mail message using the e-mail address and subject line specified in this 

dialog box.  

 

A mailto URL is a special type of URL used by e-mail systems.   

Modifying and Deleting Hyperlinks 
Hyperlink addresses are unique, specific locations to a document, whether it is stored on the Internet, the local 

intranet or a local computer. If you move or rename the referenced document, you must change the hyperlink. 

You may also want to change the text displayed in the worksheet for the hyperlink or add a custom ScreenTip. 

When you no longer need the hyperlink, you can remove the reference. The text displayed for the hyperlink remains 

in the cell. 

To modify a hyperlink in the worksheet, use one of the following methods: 

 Right-click the hyperlink and then click Edit Hyperlink; or 

 move the cell pointer to the cell containing the link and then, on the Insert tab, in the Links group, click 

Hyperlink to display the Edit Hyperlink dialog box. Make the necessary changes and close the dialog box. 

To delete a hyperlink in the worksheet, use one of the following methods: 

 Right-click the link and then click Remove Hyperlink; or 

 move the cell pointer to the cell containing the link and then, on the Insert tab, in the Links group, click 

Hyperlink to display the Edit Hyperlink dialog box. Click Remove Link. 

 

Learn the Skill 
This exercise demonstrates how to create and modify hyperlinks in an Excel workbook. 

1 Open the Financial Statements workbook and save it as Financial Statements – Student. 

  

Insert a hyperlink to a website in cell B3. 

2 Select cell B3. 

3 On the Insert tab, in the Links group, click Hyperlink. 
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4 Click in the Address field and type: http://tolanoadventures.com. 

5 Click in Text to display and change the contents to: Tolano Adventures. 

  

6 Click OK. 

Now insert two hyperlinks to other workbooks. 

7 Select cell B5. 

8 On the Insert tab, in the Links group, click Hyperlink. 

9 Scroll down and select the Income Statement workbook. If necessary, select a different folder in the Look 

in list where the data files are located, as directed by the instructor. 

10 Click OK. 

11 Right-click in cell B7, then click Hyperlink. 

12 Scroll down and select the Balance Sheet workbook and click OK. 

Test one of the hyperlinks by clicking on it.  

13 Position the mouse cursor over the hyperlink in cell B5; the cursor changes to a white pointing hand. 

Notice that a screen tip will appear with the URL for the Income Statement workbook. 

14 Click the Income Statement hyperlink. 

 The Income Statement workbook is now open on top of the Financial Statements workbook. 

15 Close the Income Statement workbook.  

 The color of the hyperlink has changed to indicate that it has been used. The worksheet should look 

similar to the following example: 

  

Now manually change one of the hyperlinks to point at a different workbook. 

16 Right-click the Income Statement hyperlink in cell B5 and then click Edit Hyperlink. 

17 In the Edit Hyperlink dialog box, scroll down and select the Income Statement – Student workbook.  
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18 Click Text to display, and change the contents to: Link to Income Statement ‐ Student. 

  
19 Click OK. 

You can change the hyperlink text directly on the worksheet without having to launch the Edit Hyperlink 

dialog box. However, if you click on the cell containing the hyperlink, the workbook will open. The next two 

steps will show you how to work around the problem.  

20 Click in cell A7 and then press the  key to make cell B7 into the active cell 

without activating the hyperlink.  

21 Press the  key to switch to edit mode, change the link text to Balance 

Sheet workbook and press . 

There are two other ways of selecting a cell without activating the hyperlink, by 

holding down the  key while clicking on the cell, or by clicking and holding down the left mouse button 

on the cell for a few seconds, until the mouse pointer changes from a hand to a white cross. Release the 

left mouse button and press the  key to go into edit mode. 

 The worksheet should now look similar to the following: 

  

Now enter a custom ScreenTip for one of the hyperlinks. 

22 Right-click the Balance Sheet hyperlink in cell B7 and then click Edit Hyperlink. 

23 In the Edit Hyperlink dialog box, click ScreenTip. 

24 In the Set Hyperlink ScreenTip dialog box, type: This is the link to the Balance Sheet workbook 

and click OK. 

  

25 In the Edit Hyperlink dialog box, click OK. 

Note… 
You can select any nearby 
cell and then use the 
cursor keys on the 
keyboard to select the 
cell. 
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26 Position the cursor over the hyperlink in cell B7 to view the ScreenTip. 

Test the change to the Balance Sheet hyperlink to make sure that it is working properly. 

27 Click the hyperlink in cell B7. 

28 Close the Balance Sheet workbook. 

Now delete one of the hyperlinks. 

29 Right-click the hyperlink in cell B7 and click Remove Hyperlink. 

The hyperlink in cell B7 has now changed to plain text. 

30 Save and close the workbook. 

⁞ Using Comments 
Comments are like “sticky” notes on a hard-copy document. You typically use them so that several users who are 

sharing a workbook can annotate the spreadsheet with their various comments. Excel automatically adds the current 

user’s name (as shown in the Excel Options dialog box located in the Backstage) at the top of the comment text box. 

The final reviewer can then act on each comment and follow up with the originator, if necessary. 

In non-workgroup situations, you can use comments to remind yourself about things you need to do or to record 

detailed information about formulas you have used for future reference. Spreadsheets typically contain large volumes 

of numbers, titles and formulas to produce the desired results. Comments often help with explanations. The 

traditional way of adding comments is to enter free-form text into cells on the worksheet. Although this method is 

simple and works well with smaller spreadsheets, it does not work well with large spreadsheets where the space 

available may be far away and you have to draw lines from your comments to the cells to which you are referring. 

Embedded comments are better because you can insert them directly into the cells and display them only when you 

want to see them.  

To insert a comment into a worksheet, use one of the following methods: 

 Select the cell where the comment will be inserted, then on the Review tab, in the Comments group, click 

New Comment; or 

 press + ; or 

 right-click the cell where the comment will be inserted and then click Insert Comment. 

To temporarily display the contents of an individual comment, position the cursor over a cell containing the 

 (Comment Symbol). When you move the cursor away, only the Comment Symbol displays. 

To force a comment to remain displayed, use one of the following methods: 

 Select the cell containing the comment, then on the Review tab, in the Comments group, click Show/Hide 

Comment; or 

 right-click the cell containing the comment and click Show/Hide Comment. 

To display the contents of all comments in a worksheet, on the Review tab, in the Comments group, click Show All 

Comments. 
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To delete a comment, use one of the following methods: 

 Select the cell containing the comment, then on the Review tab, in the Comments group, click Delete; or 

 right-click the cell and then click Delete Comment; or 

 select the cell containing the comment, then on the Home tab, in the Editing group, click Clear, and then 

click Clear Comments.  

 

Learn the Skill 
In this exercise, you will insert comments into a worksheet. 

1 Open the Income Statement - Student workbook. 

2 Select cell C6. 

3 On the Review tab, in the Comments group, click New Comment. 

4 In the comment box, type: Revenue source was sales of souvenir T‐shirts. 

 The worksheet appears as follows with the comment displayed. 

  

5 Click anywhere on the worksheet away from the comment. 

Excel displays a  (Comment Symbol) in this cell to remind you that you have inserted a comment 

there; otherwise, the comment would remain hidden until you placed the cursor over that cell. 

6 With the current active cell elsewhere on the worksheet, move the cursor over cell C6. 

 The comment box reappears and continues to display until you move the cursor elsewhere. 

7 Select cell C20 and, on the Review tab, in the Comments group, click New Comment. 

8 In the comment box, type: Net income needs to be improved! 

9  Click elsewhere on the worksheet. 

  If necessary, you can display all comments on a worksheet at one time. You may want to do this if you are 

seeing the worksheet for the first time, or if others have added many comments since you last opened the 

workbook. 

10 Select cell C20 again and then, on the Review tab, in the Comments group, click Show/Hide Comment. 

Click elsewhere on the worksheet. 
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You can now hide the comment again. 

11 Select cell C20 and then, on the Review tab, in the Comments group, click Show/Hide Comment again. 

You can also make all the comments in the worksheet display at the same time. 

12 On the Review tab, in the Comments group, click Show All Comments. 

  

13 On the Review tab, in the Comments group, click Show All Comments again to hide all comments. 

14 On the Review tab, in the Comments group, click Next. 

15 Click the Next button two more times until Excel displays a message box. 

16 Click Cancel to close the message box and click elsewhere on the worksheet. 

You can delete a comment from a cell when you no longer need it. 

17 Select cell C6. Then on the Review tab, in the Comments group, click Delete. 

18 Save and close the workbook. 

⁞ Importing and Exporting Data 
Importing Data Files 
Most businesses use various specialized computer systems for their operations. Typically these systems reside on 

servers, other PCs, or even mainframe computers. The challenge has always been trying to move data from one 

system to another without having to manually re-enter the data. Almost all of these systems have the ability to export 

data into files, and the text data file format is the most commonly used.  

Because Excel uses a customized binary format for its own workbook data, it has to convert external data files by 

importing them.  
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On the Data tab, in the Get External Data group are four icons used for importing external data: 

  

The From Other Sources button shows a drop down menu for the remaining options for importing data: 

 

These import options are as follows: 

From Access Imports directly from a Microsoft Access database. 

From Web Imports data that is displayed in specific locations of a web page. 

From Text Imports data from a file containing numeric and alphabetic data in text format.  

From SQL Server Imports data from a Microsoft SQL Server database. 

From Analysis 

Services 

Imports data from the Analysis Services module, a component of Microsoft SQL Server. 

From XML Data 

Import 

Imports data from a XML-formatted file. The XML format is rapidly becoming a standard 

format for exchanging data between different systems.  

From Data 

Connection Wizard 

Imports data using a data connection (such as ODBC) to another system.  

From Microsoft 

Query 

Imports data using the Microsoft Query module.  

The text format has at least three sub-formats: 

 Delimited: The text data is separated by a pre-defined character such as comma, tab, semi-colon, blank 

space, or possibly other characters. Excel uses this delimiter to separate the line of text into separate values 

to be inserted into each worksheet cell. 

 Fixed width: Each value has a specific start and end position in every line of text. Excel uses the position of 

the text to separate the data into each worksheet cell. 
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Learn the Skill 
In this exercise, you will import a comma delimited text file into a worksheet. 

1 Create a new blank workbook. 

2 On the Data tab, in the Get External Data group, click From Text. 

 The Import Text File dialog box is displayed.  

3 Locate and select the Eco Cruises.txt file and click Import in the Import Text File dialog box. 

 The Text Import Wizard will start automatically. 

   

The Original data type section has two options: Delimited and Fixed width. Use the Delimited option if 

the data is compressed together with no gaps between the values, and delimiter characters (such as 

commas and tab characters) to separate each value from the next. Use Fixed width if the values are 

vertically aligned, and blank spaces are inserted into the data where necessary. The Preview section at 

the bottom of this Wizard shows the data in each line pushed together, so it is obviously not a Fixed width 

type.  

The File origin text box allows you to select whether the data originated from a computer using the 

Macintosh, DOS, Windows (ANSI), or a variety of foreign language formats. 

4  Verify the Original data type is Delimited, and Start import at row is 1, then click Next. 

 In Step 2 of the Text Import Wizard, you specify the delimiter character from the list of options: Tab, 

Semicolon, Comma, Space, or Other. You can select more than one type of delimiter character.  

 You also specify the type of Text qualifier: double-quote (") or single quote ('). Text qualifiers are used to 

identify text characters that belong together. For this data file, none of the data is using any text qualifier.  
Fo

r E
va

lu
at

io
n 

Onl
y



Lesson 3 Analyzing, Organizing and Sharing Workbooks 
 

80   6277-1 v1.00 © CCI Learning Solutions Inc. 

  

5  In the Delimiters section, verify the Tab check box is turned on and click Next. 

Step 3 of the Text Import Wizard tries to guess the correct type of data used in each column. The default 

type is General, in which a column with data that appears to be all numeric will be converted into a 

number. Similarly, data that appears to be recognizable date values will be converted into dates, and any 

remaining types will be treated as text. You can also force Excel to accept columns as date or text, or to 

skip the entire column.  

   

6  Click Finish. 

   

7  Click OK. 

Fo
r E

va
lu

at
io

n 
Onl

y



Analyzing, Organizing and Sharing Workbooks Lesson 3 
 

6277-1 v1.00 © CCI Learning Solutions Inc.  81 

 The worksheet should appear similar to the following: 

  

8  Save the workbook as Eco Cruises ‐ Student and close it. 

Exporting Data from Excel 
Excel provides an easy-to-use method of exporting data to other systems. In the Save As dialog box, the Save as 

type drop down list includes an extensive list of different formats for saving the worksheet data: 

 

Another method of sending data to another Windows program is to use the Windows Clipboard. To use it, simply 

copy the data from Excel into the Clipboard, and paste the data into the other Windows program. The target software 

will usually offer several options, such as copying the data formatting as well.  

 

Learn the Skill 
In this exercise, you will export worksheet data to a comma-delimited text file, and copy and paste the data 
to a Microsoft Word document. 

1 Open the Flights workbook. 

Export this worksheet to an external CSV data file.  

2 Click the File tab, then click Save As. 

3 Click the arrow at the far right of the Save as type, and select CSV (Comma delimited) (*.csv). 

4 With the File name as Flights.csv, click Save. 
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 A warning message box appears to inform you that the data from only the current worksheet will be 

exported to the data file. 

  

5  Click OK. 

A second warning message box appears to inform you of possible data incompatibilities. Do not be overly 

concerned about the warning—you can just verify the output to make sure that the data looks correct. 

  

6 Click Yes. 

Use MS Notepad to check the contents of the output file.  

7  Start up Notepad from the Windows Start button. 

8 In Notepad, click File, Open from the menu. 

9 Change the document type from Text Documents (*.txt) to All Files (*.*). 

10 Locate and select the Flights.csv file and click Open. 

   

11 Close Notepad without saving any changes. 

12 Go back to Excel and close the Flights.csv file. 
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Now try copying and pasting the worksheet data to Microsoft Word using the Clipboard.  

13 Open the Flights workbook. 

14 Select columns A, B, C, and D, and on the Home tab, in the Clipboard group, click Copy. 

15 Start up Microsoft Word with a new blank document. 

16 In Word, on the Home tab, in the Clipboard group, click the arrow under Paste, and click Paste Special.  

17 Select Formatted Text (RTF) and click OK. 

18 Save and close the Word document as Flights ‐ Student. 

19 Go back to Excel and close the Flights workbook without saving any changes. 

Changing Workbook Properties 
Another useful tool for workgroups is the ability to display a workbook’s properties prior to opening it. This is useful 

when there are many workbooks stored on the network server, often with very similar names. The properties display 

will help distinguish each of the workbooks from each other. 

These same benefits apply in non-workgroup situations as well. 

It is good practice to view the document properties before saving your workbook for the first time or sending it to 

others. Sometimes the document properties may contain confidential data about you or your company that you 

should not be sharing with others.  

 

Learn the Skill 
In this exercise, you will display and change the workbook properties. 

1 Open the Financial Statements - Student workbook. 

2 Click the File button, click Info, and then click Properties, and click Show Document Panel.  

 The Document Properties panel is displayed above the workbook. 
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3 Type the following: 

  Author: <your own name> 

  Title: Tolano Adventures 

  Subject: financial statement 

  Keywords: links, website, income statement, balance sheet 

  Category: financial 

  Status: Draft 

4 Click Document Properties and then Advanced Properties. 

  

5 Click each of the tabs and you will see that entering the information in the Document Properties panel is 

the same as with Windows, except that you can see the contents of the document at the same time, which 

enables you to enter more precise details about the document. 

6 Click OK to close the dialog box. 

7 Close the Document Properties panel. 

8 Save and close the workbook. 

⁞ Sharing Workbooks 
The rapid adoption of the Internet into everyday life demonstrates how communication helps people to connect in 

social and work settings. Today’s workplace leverages the power of technology to increase worker productivity in 

creating, analyzing and sharing data, leading to faster and more informed decision-making. Most office workers now 

have at least one computer, and almost every one of them connects to the others using the corporate local area 

network.  

Excel taps into this pervasive connectivity with its built-in ability to send workbooks to others using e-mail, the 

Internet, and Microsoft SharePoint.  
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Using E-mail 
One way of sharing workbooks quickly with others is to send them by e-mail. The downside of using e-mail is that 

every recipient gets his or her own copy of the workbook. These individuals often make changes or add comments to 

their copy of the workbook and send it back. The originator must then merge these copies together.  

To send a workbook using e-mail from within Excel, do the following steps: 

1. Open the workbook. 

2. On the File tab, click Save & Send. 

  

3. Ensure Send Using E-mail is selected and then click one of the following buttons: 

 a.  Send as Attachment 

 b.  Send a Link 

 c.  Send as PDF 

 d.  Send as XPS 

 e.  Send as Internet Fax 

Fo
r E

va
lu

at
io

n 
Onl

y



Lesson 3 Analyzing, Organizing and Sharing Workbooks 
 

86   6277-1 v1.00 © CCI Learning Solutions Inc. 

Send as 

Attachment 

Create a new e-mail message with your workbook included as an attachment, as demonstrated 

in the following example: 

 
When you click the Send button, Outlook sends the e-mail and the attached workbook to the 

intended recipient. 

Send as 

Link 

Launch Outlook with a new e-mail message containing a hyperlink to your workbook. Unlike 

Send as Attachment, Send as PDF or Send as XPS, your recipients do not receive any file; 

instead, they open the original workbook by clicking on the hyperlink in the e-mail. Note that 

your workbook must be stored in a shared location (e.g., a network drive) where your recipients 

can access it from wherever they are located. 

Send as 

PDF 

Convert the workbook into a PDF (Portable Document Format) before you send it. Then 

Outlook creates a new e-mail message with this PDF file included as an attachment, as 

demonstrated in the following example: 

 
The PDF format allows the recipient to view and print the workbook, but it does not permit them 

to make changes.  

Send as 

XPS 

Convert the workbook into XPS format before sending. As with Send as PDF, Excel converts 

the workbook and then Outlook creates a new e-mail message with this XPS file included as 

an attachment; recipients can view and print the workbook but they cannot make changes to it. 

Send as 

Internet Fax 

Convert the workbook into an electronic fax file and send it to the internet fax software installed 

on your local computer. 
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Of these alternatives, you should select Send as Link as your preferred method when sharing with co-workers within 

the same organization. Avoid sending a workbook as an attachment because you will simply create more work for 

yourself when your co-workers make changes to their copies of the workbook, possibly at the same time as you are 

doing so. If instead you put the workbook into a shared location and send out a link, everyone (including you) is 

always updating the same workbook.  

The Send as PDF or Send as XPS are useful alternatives if you want to prevent the recipients from making changes 

to the workbook.  

Save to Web 
Another way of sharing workbooks with others is to use a web-based storage service such as the Microsoft SkyDrive. 

SkyDrive is one of the components of the Microsoft’s Windows Live group of online services. Every registered 

Windows Live user has a SkyDrive with 25 GB of storage space at no cost. By default, you have two main folders: My 

Documents and Public. Anyone with a Windows Live ID can access any files in the Public folder at any time; any files 

you put into the My Documents folder are only accessible by you, except for the ones that you designate your 

contacts can share. You can also add other online web-based (e.g. Internet) storage services to store your 

workbooks.  

To save a workbook to the SkyDrive from within Excel, do the following: 

1. Open the workbook. 

2. On the File tab, click Save & Send. 

3. Under Save & Send, click Save to Web. 

  

4. If necessary, click Sign In to access the SkyDrive. 

5. Enter your login ID and password in Windows Live. 

 Excel then displays the folders in your SkyDrive.  Fo
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6. Click one of the SkyDrive folders (e.g. Public or My Documents) and then click Save As. 

The Save As dialog box appears (there may be a short wait while the connection is completed with the 

SkyDrive). Although it looks like any other folder on your computer or a network drive, it is actually a remote 

drive provided as part of your Windows Live account. If you want to share your workbook with others, be sure 

to select the Public folder.  

7. If desired, change the File name and/or Save as type. 

8. Click Save. 

9. If necessary, make any other changes to the workbook and save these changes. Note that, any time you 

save changes, you are saving them directly to the workbook in the SkyDrive, not to your local computer.  

10. Close the workbook. 

 The workbook is now accessible from the SkyDrive.  

Using SharePoint 
Another method of sharing Excel workbooks (and other documents) with co-workers is by using SharePoint. 

Recognizing that people working together are more productive than people working alone, Microsoft designed 

SharePoint to facilitate document sharing within an organization and with authorized users in partner organizations. 

The term web-based collaborative environment refers to this kind of online sharing. 

SharePoint brings together the many different tools that people use to share, including: 

 Shared network drives to store files and documents—In the past, a company or IT department would 

designate specific computers to store these files. Access security quickly followed to ensure protection of 

confidential files. However, the demand for shared storage space in an organization usually exceeds the 

space available after a few years, representing an ongoing administrative nightmare for most IT 

departments.  

 Document version control—A collaborative environment brings a new set of challenges and headaches, 

primarily the dispersal of ownership and loss of control over changes made, which often leads to 

uncontrolled and haphazard changes. For example, someone may delete a document accidentally or make 

changes that conflict with another person’s changes. Version control ensures that only one person enters 

their changes at any one time. If someone accidentally deletes a document or makes unwanted changes, 

this feature allows you to restores a previous version easily.  

 Workflow control—You can designate documents to be funneled through workflow processes, such as 

approving purchase requisitions or media releases. The system then automatically routes the document to 

the next person in the workflow when the current approver has completed his or her work.  

 Social networking—Facebook is an example of social networking.  
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 E-mail—Announcements, notices and other types of team communication, which are often sent by e-mail, 

can be quickly lost in the daily volume of other e-mail. An effective collaboration site has a section containing 

the most relevant communications to the team without having to wade through e-mails.  

 Other shared communications—These include things such as corporate or team calendars, surveys and 

polls.  

To save a workbook to SharePoint from within Excel, do the following: 

1. Open the workbook. 

2. On the File tab, click Share. 

3. Under Share, click Save to SharePoint. 

   

4. If necessary, click Browse for a location. 

The Excel Save As dialog box now appears, allowing you to navigate to the SharePoint site where the 

document is to be stored.  

A SharePoint site can be designed in many different ways; the following illustration shows one example 

where documents of various types are stored. 
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⁞ Lesson Summary 
In this lesson, you learned to work with different types of illustrations, including shapes, WordArt, pictures, clip art 

graphics and SmartArt. You should now be able to: 

 sort data 

 use the AutoFilter feature to find specific data 

 create, modify and delete range names 

 create, modify and delete hyperlinks 

 create and delete comments 

 import and export data with other programs 

 change workbook document properties 

 use Office BackStage to share workbooks with others. 

⁞ Review Questions 
1. What is the difference between sorting and filtering? 

2. What can you use the AutoFilter tool for in a worksheet? 

3. Why do you need to tell Excel whether you have headers in the data? 

4. Provide examples of when you might set up multiple levels for sorting. 

5. Give examples of why you might want to name cell ranges instead of using the cell references. 

6. What restrictions are in place regarding range names? 

7. What can you use the Name Manager for? 

8. Give an example of when you might insert a hyperlink into a worksheet. 

9. What can you use comments for in a worksheet? 

10. What is the preferred method of sharing a workbook with your co-workers, and why? 
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